Back to overview
Maintenance

Applying updates

Jan 23 at 10:30am CET  –  Jan 23 at 11:29am CET
Affected services
SupportMail Client

Resolved
Jan 23 at 11:29am CET

Maintenance completed, updates applied, nothing wrong so far.

Thank you for your patience.

Updated
Jan 23 at 11:08am CET

The updates have been applied, minor issues have occurred which are being addressed.

Created
Jan 23 at 10:30am CET

Applying updates